Apps
Knowledge
People
Register
Login


-
- Content .- Fans  .- Knowledge Base  . 

jappix

   0.2  

ownCloud Tool

Score 53%
jappix
zoom


jappix
zoom


Homepage:  Link
Minimum required   ownCloud 6
Maximum required   ownCloud 7
Downloads:  731
Submitted:  Oct 23 2014
Updated:  Oct 30 2014

Description:

xmpp chat app for OwnCloud based on Jappix Mini (standalone).
Requires an external XMPP server...

N.B. Be sure the php5-mcrypt module is intalled !

For this very first version, user must have the same credentials (login and password) in owncloud and on the xmpp server (what I needed ;-).




LicenseAGPL
All Versions
Send to a friend
Subscribe
Other  Apps  from jerome-b
Report inappropriate content



-
.

 No news, good news ?

 
 by jerome-b on: Oct 28 2014
 
Score 50%

75 downloads in a few days, and no comment !


Reply to this

-
.

 Chat for minimalists

 
 by ScriptFanix on: Oct 28 2014
 
Score 50%

When I wanted to add chat support in my ownCloud, I wanted something light and discreet. This is exactly what I was looking for.

Few quirks I've encountered so far:
  • lack of documentation (but I'm sure you're aware of that)

  • When you submit a wrong configuration, and then a valid one, the "Error!" message does not disappear

  • Something more specific than "Error!" would be nice too :)

  • Reply to this

    -

     Re: Chat for minimalists

     
     by jerome-b on: Oct 28 2014
     
    Score 50%

    Thanks, ScriptFanix for your return.
    You are right : lack of documentation, for sure, but I imagine that those who have an xmpp server know about a bosh url, an xmpp domain... I will do my best to improve that.
    But "when you submit a wrong configuration, and then a valid one, the "Error!" message does not disappear", you're right, it's a bug that I fixed in 0.2 version that I just uploaded to the site. thanks.
    And if the message (error or success) is not specific (I agree) it's because it only says you if your configuration has been saved (in owncloud), not if it works (in jappix). Still a lot work to do for that...


    Reply to this

    -

     breaks admin interface

     
     by leonisholding on: Oct 29 2014
     
    Score 50%
    leonisholdingleonisholdin g
    Leonis Holding GmbH
    Home

    Interesting application but unfortunately causes JS issues, thus breaking the admin interface. Made even disabling impossible.

    Environment:
    Ubuntu 14.04
    ownCloud 7.0.2
    DB Postgres 9.x

    Hint for other Postgres users for manual uninstallation:
    access your postgres shell
    1. use owncloud database
    ~# \c your_owncloud_database

    2. check if app is there & enabled
    ~# select * from oc_appconfig order by appid;

    3. doublecheck for entries
    ~# select * from oc_appconfig where appid = "jappix";

    4. remove
    ~# delete from oc_appconfig where appid = 'jappix';


    Reply to this

    -

     Re: breaks admin interface

     
     by jerome-b on: Oct 29 2014
     
    Score 50%

    Can you tell us more about the problem you encountered? Your Xmpp server, for example ? Or error messages in the logs?


    Reply to this

    -

     Re: Re: breaks admin interface

     
     by leonisholding on: Oct 29 2014
     
    Score 50%
    leonisholdingleonisholdin g
    Leonis Holding GmbH
    Home

    Some more details to the previous comment: It breaks the admin interface of ownCloud due to JavaScript errors.

    1. app interface becomes unresponsive
    2. disabling the plugin was not possible as the admin interface was not rendered
    3. administation interface (admin account) showed glitches
    4. layout of administration interface was broken after reload

    We accessed the administration interface with the Chromium browser. Sadly cannot reproduce for console outputs, as the app is not installed anymore.


    Reply to this

    -

     Re: Re: Re: breaks admin interface

     
     by jerome-b on: Oct 29 2014
     
    Score 50%

    Difficult to tell what occured to you ... Bad information fields? Bad response from the server ?
    It would have been usefull to see the ajax response... Sorry for you !


    Reply to this

    -

     Re: Re: Re: Re: breaks admin interface

     
     by leonisholding on: Oct 29 2014
     
    Score 50%
    leonisholdingleonisholdin g
    Leonis Holding GmbH
    Home

    Yes, unfortunately the error log was very unclear. The browser console also just showed some conflicts with jQuery 1.10.0. Too bad, we'd really appreciate this application.

    In any case we are going to deploy an ownCloud testing instance, so we'll let you know about a more in detail error log, ok?


    Reply to this

    -

     Re: Re: Re: Re: Re: breaks admin interface

     
     by jerome-b on: Oct 29 2014
     
    Score 50%

    Yes, sure ! And if you can tell me what is your xmpp server ? Ejabberd, Metronome ? Prosody ? And if it is cross-domain errors ?


    Reply to this

    -

     Re: Re: Re: Re: Re: Re: breaks admin interface

     
     by leonisholding on: Oct 29 2014
     
    Score 50%
    leonisholdingleonisholdin g
    Leonis Holding GmbH
    Home

    It is an ejabberd within our server cluster, so there should be no cross-domain issues.

    The trouble started earlier and was frontend-wise, so we did not even had the option to establish a connection to ejabberd.

    We will deploy the testing instance within a couple of days, so we can find out more.



    -

     Record a password in app setting (LDAP backend)

     
     by lunarok on: Dec 19 2014
     
    Score 50%

    Hi,

    I use owncloud with a LDAP backend for users and authentification.
    So in your app, when I open the getsettings, the password is blank. It is not stored in OC I must understand.

    Could it be possible to add a field to add it on user setting ?
    My XMPP server is using also the LDAP for backend, so yes the users are same and shared.
    Something like "if password is set in user setting, use it, else use the one stored in OC"


    Reply to this

    -

     Re: Record a password in app setting (LDAP backend

     
     by jerome-b on: Dec 20 2014
     
    Score 50%

    Hi,

    No matter what is your backend, because jappix use the data you enter in the login form of owncloud... But are sure that the login of the user is the same ? Perhaps one is usin the domain and not the other. It must be easy to correct this... if you tell me more...
    Regards,

    Jérôme


    Reply to this

    -
    .

     Not working

     
     by crsBR on: Feb 3 2015
     
    Score 50%

    when active, this app crashes my owncloud installation.

    I have to disable the app in the database, to display any pages again.

    In the admin page the following error appears
    Error PHP Undefined index: jm_pwd at /var/www/owncloud/apps/jappix/ajax/getsettings.php#18

    owncloud version 7.0.4 (stable).


    Reply to this

    -

     Re: Not working

     
     by jerome-b on: Feb 4 2015
     
    Score 50%

    Can you tell me what is your authentication mode and if you have other 3rd party apps ?


    Reply to this

    -

     Re: Re: Not working

     
     by crsBR on: Feb 4 2015
     
    Score 50%

    Jappix Mini is the only third-party app.

    Authentication mode is LDAP (Samba 4 Active Directory) in owncloud and openfire 3.9.3.

    When the app is active the left panel in owncloud loads, but the right panel keeps empty, the admin interface is loaded but the configs are empty, also the animated icon in connectivity checks keeps spinning forever.
    Any user can connect meaning LDPA is working, but no documents, no photos, no calendars are displayed.

    when I disable the app in the database, everything is back to normal.


    Reply to this

    -

     Almost Working now

     
     by crsBR on: Feb 4 2015
     
    Score 50%

    I think the problem was the permissions in the apps folder, I have changed the permissions using chwon -R www-data:www-data app/jappix

    Tried enabling the app again, this it failed the first time, and got working the second time, now i can see the configuration options.


    Reply to this

    -

     Re: Almost Working now

     
     by jerome-b on: Feb 5 2015
     
    Score 50%

    Almost working or working ?


    Reply to this

    -

     Re: Re: Almost Working now

     
     by crsBR on: Feb 6 2015
     
    Score 50%

    Almost, I managed to start the application, but I'm having trouble configuring the bosh url for my environment, I'm searching for tips around the internet.


    Reply to this

    Add commentBack




    -
     
     Who we are
    Contact
    Register
    Explore
    Apps
    Knowledge
    People
    Participate
    Add App
    Public API
    About apps.ownCloud.com
    Legal Notice
    Report Abuse
     

    Copyright 2011-2016 apps.ownCloud.com Team  
    All rights reserved. apps.ownCloud.com is not liable for any content or goods on this site.
    All contributors are responsible for the lawfulness of their uploads.